Update kicks out my personal receiver-jpg

If you have a suggestion for a feature, post it here
Post Reply
Silencer
Posts: 8
Joined: Sun Jun 21, 2015 8:47 pm

Update kicks out my personal receiver-jpg

Post by Silencer »

Since UMS does not have the right picture of my Yamaha R-N2000a, I added it manually into the ums.jar and edited the *.conf-file. All good ... until I updated today. The update overwrote the ums.jar without caring about my changes. Can you please keep usermade adaptions within the updated files? yamaha-AV.conf and ums.jar.
Thank you.
User avatar
mik_s
Moderator
Posts: 1180
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Update kicks out my personal receiver-jpg

Post by mik_s »

I think it is possible to link to an image on your computer instead of adding it to the jar file as this will always be overwritten when UMS updates.

I have never used this so not sure how it works. It might need a full path to the image or the image has to be in the same folder as the conf file and only use the filename in the RendererIcon

If you are using a modified existing conf for your renderer it will get overridden too unless you give it a different name and increase its loading priority so it will be used over the default one. I usually add "-mod" to any confs I alter.

You can also store them in the "C:\ProgramData\UMS" folder where the installer will not touch them unless you do a clean install.


Edit:
I did a quick test and this works, just copy your icon to the same folder as the renderer confs and just use the filename in RendererIcon.
It did not work entering the full path though.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Silencer
Posts: 8
Joined: Sun Jun 21, 2015 8:47 pm

Re: Update kicks out my personal receiver-jpg

Post by Silencer »

Thank you for reply.
Okay, I may have done something wrong when updating to 14.0.* It works now with picture in same folder as the renderer confs. But I didn't get it how to increase the loading priority of that edited *.conf. I put it into C:\ProgramData\UMS folder, but the update 14.1.0 overwrote the *.conf in the renderers directory. The edited *.conf in C:\ProgramData\UMS was not touched, as you said, but this file was not loaded (or too late) - so I did not get the right picture at the end.

When I delete the *.conf in the renderers directory, no picture shows up at all.
User avatar
mik_s
Moderator
Posts: 1180
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Update kicks out my personal receiver-jpg

Post by mik_s »

Use the option LoadingPriority in your conf and make sure this is set higher than the original conf so it will be loaded first.

Code: Select all

# The loading priority of this renderer. This should be set to 1 (or greater)
# if this renderer config is a more specific version of one we already have.
# For example, we have a Panasonic TVs config that is used for all
# Panasonic TVs, except the ones we have specific configs for, so the
# specific ones have a greater priority to ensure they are used when
# applicable instead of the less-specific renderer config.
# Default: 0
LoadingPriority = 
When I tested this I just copied an icon to the renderer folder in "C:\Program Files (x86)\Universal Media Server\renderers\".
Maybe loading of images only work from this folder. When I tried adding a full path to another drive the icon did not show for me either.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Silencer
Posts: 8
Joined: Sun Jun 21, 2015 8:47 pm

Re: Update kicks out my personal receiver-jpg

Post by Silencer »

Okay, thanks!
Post Reply