UMS with Vizio Smart TV

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Kjott
Posts: 2
Joined: Mon Dec 07, 2015 9:08 am

UMS with Vizio Smart TV

Postby Kjott » Mon Dec 07, 2015 10:18 am

I'm trying to use UMS with a Vizio Smart TV. I just want to be able to play my media files without it taking forever to transcode/load them. I basically have a series of problems and questions about it.

For some reason, every time I go to browse my "Shared" folder on my TV, it takes several minutes open the folder. Once the folder is opened, I still can't navigate to select a file to play. It seems to be transcoding my files (ffmpeg64.exe using a lot of cpu) during this process. This makes navigating folders with transcoded files inside of it painfully slow. This is what the logs show when I try to open the Shared folder:

16:43:21 INFO Checking shared folder: D:\Shared
16:43:25 INFO Started playing Arrow.S04E03.HDTV.x264-LOL.mp4 on your Vizio Smart TV
16:44:57 INFO Started playing Arrow.S04E04.720p.HDTV.X264-DIMENSION.mp4 on your Vizio Smart TV
16:44:59 INFO Stopped playing Arrow.S04E03.HDTV.x264-LOL.mp4 on your Vizio Smart TV
... continues and cycles through all of my files

I guess this could be a problem with my TV requesting the files in order to gather the file details. Therefore, my next action was to exclude mp4 files from transcoding in the UMS options. This solves the previous folder navigation problem, but only 1 out of 4 of my mp4 files successfully plays. On one of the files, I get some weird error message on my TV:

Audio not supported
Video format not supported

Another file just shows a black screen when I try to play it. However, I can successfully play all of these mp4 files from a flash drive connected to the TV. Is UMS making some other changes to my files besides "transcoding"? Can I make UMS transmit my files as-is like on my flash drive? The mp4 file that works is Arrow.S04E04.720p.HDTV.X264-DIMENSION.mp4; it uses "Dolby D" audio.

One solution I have is to put every video in a separate folder, so navigating is much faster. However, doing so still transcodes the file twice each time I want to play it:

17:00:18 INFO Checking shared folder: D:\Shared
-- I select the Arrow4 folder to navigate to Shared/Arrow4/
17:00:24 INFO Started playing Arrow.S04E04.720p.HDTV.X264-DIMENSION.mp4 on your Vizio Smart TV
17:04:20 INFO Stopped playing Arrow.S04E04.720p.HDTV.X264-DIMENSION.mp4 on your Vizio Smart TV
-- The contents of the Arrow4 folder finally appear, so I select the video, and it transcodes again
17:04:25 INFO Started playing Arrow.S04E04.720p.HDTV.X264-DIMENSION.mp4 on your Vizio Smart TV
-- Finally, video starts playing on my TV at 17:08:20

I really don't want to have to wait 8 minutes to start a video. I have "Enable GPU acceleration" on (GTX 750 Ti). I might move my videos onto my SSD later, but I doubt that will make much of a difference.

Is the transcoding process supposed to lock up my TV like this? I'd imagine it would be possible to begin playing the video as the rest of video transcodes.

My TV:
http://www.newegg.com/Product/Product.a ... 6889262401

I'm all out of ideas. If anybody can help me I'd be very happy!
Last edited by Kjott on Tue Dec 08, 2015 7:45 am, edited 1 time in total.

User avatar
valib
Developer
Posts: 433
Joined: Fri Feb 08, 2013 3:11 am

Re: UMS with Visio Smart TV

Postby valib » Mon Dec 07, 2015 10:42 am

Please follow the Forum rules written in red above to be able to help you.

Kjott
Posts: 2
Joined: Mon Dec 07, 2015 9:08 am

Re: UMS with Visio Smart TV

Postby Kjott » Mon Dec 07, 2015 11:21 am

I attached them to this post.
Attachments
with_transcoding.zip
with mp4 transcoding
(52.23 KiB) Downloaded 55 times
no_transcoding.zip
without mp4 transcoding
(43.29 KiB) Downloaded 41 times

Rhialto
Posts: 11
Joined: Mon Jan 13, 2014 1:47 am

Re: UMS with Vizio Smart TV

Postby Rhialto » Sat Jul 30, 2016 1:21 pm

Hi,

Just bought that HDTV and I'm very impressed so far for the price, I'm usually hard to satisfy regarding colors and image quality. Whatever...

Just like you, it's incredibly slow to navigate in folders. The first time I thought it froze but then I decided to wait and after 3-4 minutes I saw the titles showing up. Unfortunatly while waiting I pressed the Exit button and TV catched it but it took another 2 minutes before the exit happen and I quit there, was too long to retry. I wonder what's wrong.

EDIT: took a quick look at the Trace tab and saw this:

INFO Buffer read ArrayIndexOutOfBoundsException error:
INFO readCount: "3238002688"
INFO maxMemorySize: "209715200"

User avatar
valib
Developer
Posts: 433
Joined: Fri Feb 08, 2013 3:11 am

Re: UMS with Vizio Smart TV

Postby valib » Wed Aug 03, 2016 9:45 am

Please follow the rules written in red above and provide the log.


Return to “General Help and Support”

Who is online

Users browsing this forum: No registered users and 4 guests