Arch Linux - UMS crashes with segfault 20 sec after start

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
xtotec
Posts: 1
Joined: Wed Mar 06, 2019 9:05 pm

Arch Linux - UMS crashes with segfault 20 sec after start

Post by xtotec » Wed Mar 06, 2019 9:38 pm

Hello,
I'm trying to run UMS on my Arch linux media server but constantly getting segfault about 20 sec after GUI shows up.
What did I tried so far
1. UMS versions - 7.9.0 from AUR, 8.0.0rc1, 7.6.1
2. java -
java-10-openjdk
java-7-jre/jre (default)
java-8-jre/jre
java-8-openjdk
tried all these too.
3. No, RAM is fine, I checked it multiple times - I'm also running serviio with about 2tb media library for about 5 years w/o any problems and doing other things on this computer (virtulabox stuff, etc...) w/o any problems (using this computer with various cpus/gpus/psu for last 13 years)
4. Trace log (attached) doesn't show anything of interest (pretty much the same for each version I tried)
dmesg says

Code: Select all

[ 1664.728611] java[5039]: segfault at 8 ip 00007f76f50df21f sp 00007f76fc927770 error 4
debug.log
(43.43 KiB) Downloaded 30 times
What should I try next? Is there any other way to extract more debug info to see what could cause it crash? Any suggestion would be appreciated.

Nadahar
Posts: 1367
Joined: Tue Jun 09, 2015 5:57 pm

Re: Arch Linux - UMS crashes with segfault 20 sec after start

Post by Nadahar » Fri Mar 15, 2019 6:44 am

It looks like this is the last thing that happens before the crash, so it is probably what causes the segfault:

Code: Select all

/usr/bin/tsmuxer -v
What happens when you run this manually from a terminal? It shouldn't be possible to achieve a segfault from Java whatever you do, so this is probably something resulting from the running of external programs, like for example tsMuxeR. There seems to be at least two versions of tsMuxeR on your system, the one bundled with UMS seems to work without any problem ("/opt/ums791/linux/tsMuxeR -v").

Post Reply