Google Music plugin

Discuss third party additions, plugins and translations for Universal Media Server
User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Wed Nov 14, 2012 7:58 am

Pls upload some logs and we'll take it from there. Works for me.

Edit. Could be a Admin rights issue. But that will be shown in the logs.
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Tue Nov 27, 2012 7:31 am

New GoogleMusic (0.20) https://github.com/downloads/SharkHunte ... in_020.jar

No real revoultion under the hood. But A-Z folder on "All Songs"
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

keit
Posts: 1
Joined: Sat Dec 01, 2012 11:54 pm

Re: Google Music plugin

Post by keit » Sun Dec 02, 2012 12:04 am

Hello!
I am a new user and tried this 0.20 Version.
My problem is, that I don´t see any songs at all.
I have empty folders a,b,c,...
Some containing a folder "more", which is empty, too.
I can see my playlist, but it has no songs it.
Any Ideas?

Greetings from Germany

Keit

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Mon Dec 03, 2012 1:45 am

keit wrote:Hello!
I am a new user and tried this 0.20 Version.
My problem is, that I don´t see any songs at all.
I have empty folders a,b,c,...
Some containing a folder "more", which is empty, too.
I can see my playlist, but it has no songs it.
Any Ideas?

Greetings from Germany

Keit
Can you pls upload the log?
And then just try and restart UMS. I've seen this some times and a restart normally helps. But FIRST upload the log!!
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

jacoby
Posts: 3
Joined: Thu Dec 13, 2012 12:22 am

Re: Google Music plugin

Post by jacoby » Thu Dec 13, 2012 12:35 am

I am having similar issues to others that have posted previously:
After some difficulty I got the plugin to recognize and load when UMS starts up.

"GoogleMusic" now appears as one of my selections. If I choose it, I get "all songs" or "playlists." My created playlists do appear as folders when I chose the playlist folder, and the a-z folders appear in 'all music,' some with an additional folder 'more.' But no music appears in anyone. There is only two entries in my log mentioning this plugin:

Code: Select all

INFO  2012-12-11 08:06:03.857 [main] Found plugin: net.sharkhunter.gmusic.Gm_plugin
and (yea, I've got a bunch of drives)

Code: Select all

INFO  2012-12-11 08:06:24.116 [New I/O server worker #1-2] Node (net.sharkhunter.gmusic.GmRoot) already has an ID (0$10), which is overriden now. The previous parent node was: RootFolder[[MapFile [name=C:\ [Terra], id=0$1, format=null, children=[]], MapFile [name=D:\ [New Volume], id=0$2, format=null, children=[]], MapFile [name=E:\ [New Volume], id=0$3, format=null, children=[]], MapFile [name=F:\ [NV_GFX560TI_SETUP], id=0$4, format=null, children=[]], MapFile [name=H:\ [HP_PAVILION], id=0$5, format=null, children=[]], MapFile [name=J:\ [SKYRIM_EN], id=0$6, format=null, children=[]], MapFile [name=M:\ [NewDrive], id=0$7, format=null, children=[]], MapFile [name=X:\ [New Volume], id=0$8, format=null, children=[]], VirtualFolder [id=9, name=Web, full path=0$9, ext=null, discovered=false]]]
After trying different things for a while I almost got it to work. I removed the latest version (020) and installed the original build (011) this version gave me an error in the log when I tried to view the songs. I felt this was an improvement. So I tried 012 and now it actually listed the tracks! But when I tried to play them, nothing played. So I tried the latest again, and the same result. At this point I tried to shut down UMS, but found that it would not shut down entirely for some reason the javaw process did not stop, so I ended the process. When I restarted UMS, once again the googlemusic folder shows up completely empty.

vedius
Posts: 10
Joined: Tue Mar 26, 2013 1:45 am

Re: Google Music plugin

Post by vedius » Tue Mar 26, 2013 1:50 am

I am getting nothing out of it at present.
Here is what if find in the log

03-25 09:36:54 Starting Universal Media Server 2.5.2.2
03-25 09:36:54 Based on PS3 Media Server by shagrath, copyright 2008-2013
03-25 09:36:54 http://www.universalmediaserver.com
03-25 09:36:54
03-25 09:36:54 Build: d758100b0 (2013-03-20)
03-25 09:36:54 Java: 1.7.0_17-Oracle Corporation
03-25 09:36:54 OS: Windows 7 64-bit 6.1
03-25 09:36:54 Encoding: UTF-8
03-25 09:36:54 Memory: 742 MB
03-25 09:36:54
03-25 09:36:54 Working directory: C:\Program Files (x86)\Universal Media Server
03-25 09:36:54 Temp directory: C:\Users\<user>\AppData\Local\Temp\universalmediaserver
03-25 09:36:54 Logging config file: C:\Program Files (x86)\Universal Media Server\logback.xml
03-25 09:36:54 debug.log: C:\Program Files (x86)\Universal Media Server\debug.log
<snip>
3-25 09:36:54 Searching for plugins in C:\Program Files (x86)\Universal Media Server\plugins
03-25 09:36:54 Found plugin: net.sharkhunter.gmusic.Gm_plugin
<snip>
03-25 09:36:56 gm exceptiuon java.io.IOException: Server returned HTTP response code: 403 for URL: https://www.google.com/accounts/ClientLogin
03-25 09:36:56 gm exceptiuon java.io.IOException: Server returned HTTP response code: 403 for URL: https://www.google.com/accounts/IssueAuthToken
<snip>

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Tue Mar 26, 2013 2:05 am

vedius - Have you added your credentials to UMS.cred? Otherwise logging in will not work.
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

vedius
Posts: 10
Joined: Tue Mar 26, 2013 1:45 am

Re: Google Music plugin

Post by vedius » Tue Mar 26, 2013 3:40 am

Here is what is in the UMS.cred file I have verified the user/pass via browser login

CODE:SELECT ALL
gmusic=[email protected],password

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Tue Mar 26, 2013 8:17 am

We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

vedius
Posts: 10
Joined: Tue Mar 26, 2013 1:45 am

Re: Google Music plugin

Post by vedius » Tue Mar 26, 2013 3:12 pm

Had to do a clean install to get this to work right.
Attachments
ums_dbg.zip
Clean install then added google creds.
(12.68 KiB) Downloaded 179 times

Post Reply