Version 5.2.2 is released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 3381
Joined: Sun May 27, 2012 4:12 pm

Version 5.2.2 is released

Post by SubJunk »

General:

You can download it from the front page.

This release improves file support, speed, translations, renderer support and more!


Changes since 5.2.1:
  • General:
    • Fixed audio transcoding with embedded images (thanks, Nadahar!)
    • Improved MIME type handling
    • Improved logging
    • Expanded filename prettifying
    • Improved renderer selection interface (thanks, Nadahar!)
    • Improved file support (thanks, Nadahar!)
    • Speed improvements
  • Renderers:
    • Improved support for Xbox 360
  • Languages:
    • Updated all languages to remove unused translations (thanks, ler0y and Nadahar!)
    • Updated Dutch translation (thanks, ler0y!)
    • Updated English (thanks, ler0y!)
    • Updated Polish translation (thanks, Karol Szastok!)
  • External Components:
    • Updated FFmpeg for Windows
    • Updated MediaInfo to 0.7.75
    • Updated Netty to 3.10.4
Tyestor
Posts: 66
Joined: Fri Oct 05, 2012 6:19 pm
Location: Brisbane, Australia
Contact:

Re: Version 5.2.2 is released

Post by Tyestor »

Nice release.

5.3 for Logging System Overhaul? Will Netty ever be 4.0 again?
ExSport
Posts: 595
Joined: Wed Oct 10, 2012 1:57 am

Re: Version 5.2.2 is released

Post by ExSport »

Netty was reverted due to some streaming problems with v4.x (streaming MP4 files etc...)
paddy
Posts: 32
Joined: Mon Jun 15, 2015 4:06 am

Re: Version 5.2.2 is released

Post by paddy »

And Thumbnail (Cover) Support for Onkyo Receivers ?

Paddy
Paradox
Posts: 145
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 5.2.2 is released

Post by Paradox »

Can one of the developers confirm if the Bravia fix has been included which affected 5.2.0 and 5.2.1. As outlined here......
viewtopic.php?f=5&t=3663
User avatar
valib
Developer
Posts: 699
Joined: Fri Feb 08, 2013 3:11 am

Re: Version 5.2.2 is released

Post by valib »

Paradox wrote:Can one of the developers confirm if the Bravia fix has been included which affected 5.2.0 and 5.2.1. As outlined here......
viewtopic.php?f=5&t=3663
Of course the fix is there.
Paradox
Posts: 145
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 5.2.2 is released

Post by Paradox »

valib wrote:
Paradox wrote:Can one of the developers confirm if the Bravia fix has been included which affected 5.2.0 and 5.2.1. As outlined here......
viewtopic.php?f=5&t=3663
Of course the fix is there.
Thanks valib will give it a go this week, keep up the good work :)
Paradox
Posts: 145
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 5.2.2 is released

Post by Paradox »

Well tried 5.2.2 and unfortunately has the same issue as 5.2.1 had on my Bravia. Incorrectly transcodes to AVC rather than MPEG-2
:( Back to 5.1.2 again :(
User avatar
valib
Developer
Posts: 699
Joined: Fri Feb 08, 2013 3:11 am

Re: Version 5.2.2 is released

Post by valib »

Paradox can you provide the log to see what is wrong? The fix you confirm as working here viewtopic.php?f=5&t=3663 is included in the 5.2.2 version.
Paradox
Posts: 145
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 5.2.2 is released

Post by Paradox »

Ill re-install it this week (is there anyway to have more than one version installed at a time??? uninstalling and re-installing versions that do not work for just logs is a bit of a pain) And post the log in another new thread as it does not appear you can attach files in the announcements section.

Definitely the same issue though. Not sure what has changed since the 5.1.x versions but all 5.2.x versions (5.2.1 and 5.2.2 do not remember 100% about 5.2.0) all have the same problem.

I also note this POTENTIALLY same issue is now possibly affecting other devices like some panasonic having the issues...
viewtopic.php?f=9&t=3881
That is what happens on my bravia when it attempts to play an MPEG-TS/AVC file rather than MPEG2 transcode. Any skipping or fast forward and it loses audio sync. Could be unrelated, but as DLNA is handled very similarly on Pansonic and Sony devices i would not be shocked if its the same issue.

Anyway cheers valib will get those logs to you this week.
Post Reply