Windows UMS Service

General discussion about Universal Media Server (no support or requests)
Post Reply
AnnieBody
Posts: 56
Joined: Thu Apr 30, 2020 3:12 am

Windows UMS Service

Post by AnnieBody »

Confused!
Having moved from Serviio (may have to move back if I can't get UMS working!), Serviio requires a Windows service to be running. No service, no Serviio.
I have received feedback regarding my other posts that I shouldn't have UMS and the Windows 'Universal Media Server' service running at the same time.
Apparently this stops the UMS program from working correctly as two versions of UMS are running at the same time.

There must be a reason for it. So what does the Windows 'Universal Media Server' service actually do?

If the Windows 'Universal Media Server' service interferes with the normal operation of the UMS program why does it get installed and run by default?

What are the implications of permanently disabling it?
User avatar
mik_s
Moderator
Posts: 297
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Windows UMS Service

Post by mik_s »

It doesn't get installed by default, only if you select the "install as a windows service" button. tbh I'm not sure the reason why its still there, I've seen it as more of a legacy thing or something for advanced users.

The service is basically UMS program without an interface (probably a bit more technical than that), thats why when executing UMS when the service is running is like running UMS twice which interferes with each other.

Don't know how Serviio works but they probably use different methods

Just disable it and that should fix your problems.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
AnnieBody
Posts: 56
Joined: Thu Apr 30, 2020 3:12 am

Re: Windows UMS Service

Post by AnnieBody »

Thanks for the reply.
I checked 'install' as this was how Serviio worked. Have it disabled now and things are working much better.
Post Reply