[Solved] V11.5.0 from Web Browser

For help and support with Universal Media Server
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
boss
Posts: 361
Joined: Thu Jun 30, 2016 1:07 pm

[Solved] V11.5.0 from Web Browser

Post by boss »

I have had a holiday from UMS for some time because of unresolved issues but thought I would try it again with V11.5.0.
I am running UMS on a headless Linux server.

This issue is the same as previous versions after version 7.4. Up to V7.4 playing videos from a browser was OK.
Videos will not play using Firefox, Edge or Chrome.

Does anyone have any suggestions?
The log file in TRACE mode is attached.

Thanks
Attachments
debug.zip
(319.19 KiB) Downloaded 236 times
boss
Posts: 361
Joined: Thu Jun 30, 2016 1:07 pm

Re: V11.5.0 from Web Browser

Post by boss »

Is anyone else having problems running video files from a browser?
From my logs, it seems as though this might be an issue:
DEBUG 2022-11-02 14:19:12.854 [ffmpeg-107] Starting /usr/bin/ffmpeg -y -loglevel fatal -hide_banner -t 6.0 -sn -i "/home/media_mnt/Videos/Movies/Bullet Train (2022).mkv" -sn -dn -copyts -s:v 640x360 -c:v libx264 -keyint_min 25 -preset superfast -profile:v main -level 30 -pix_fmt yuv420p -c:a aac -ac 2 -ab 160000 -f mpegts -skip_estimate_duration_from_pts 1 -use_wallclock_as_timestamps 1 -movflags frag_keyframe /tmp/UMS-root/ffmpeghlsvideo_237_1667369952553
DEBUG 2022-11-02 14:19:12.855 [ffmpeg-107] Reading pipe: /tmp/UMS-root/ffmpeghlsvideo_237_1667369952553
DEBUG 2022-11-02 14:19:12.857 [ffmpeg-107-2] Error splitting the argument list: Option not found
DEBUG 2022-11-02 14:19:14.062 [pool-3-thread-18] External input stream instance is null... sounds not good, waiting 500ms
boss
Posts: 361
Joined: Thu Jun 30, 2016 1:07 pm

Re: V11.5.0 from Web Browser

Post by boss »

Guess I am going back on holidays again. :D
User avatar
mik_s
Moderator
Posts: 1181
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: V11.5.0 from Web Browser

Post by mik_s »

Sorry I missed this, not been on that often recently.

Code: Select all

DEBUG 2022-10-23 14:50:45.894 [ffmpeg-38] Starting /usr/bin/ffmpeg -y -loglevel info -t 6.0 -sn -i "/home/media_mnt/Videos/Movies/Baby Driver (2017).mp4" -sn -dn -copyts -s:v 640x360 -c:v libx264 -keyint_min 25 -preset superfast -profile:v main -level 30 -pix_fmt yuv420p -c:a aac -ac 2 -ab 160000 -f mpegts -skip_estimate_duration_from_pts 1 -use_wallclock_as_timestamps 1 -movflags frag_keyframe /tmp/UMS-root/ffmpeghlsvideo_162_1666507845589

DEBUG 2022-10-23 14:50:45.898 [ffmpeg-38-2] Unrecognized option 'preset'.
DEBUG 2022-10-23 14:50:45.898 [ffmpeg-38-2] Error splitting the argument list: Option not found

ERROR 2022-10-23 14:50:52.143 [Hanging External Process Stopper] External input stream instance is null... stopping process
DEBUG 2022-10-23 14:50:52.143 [Hanging External Process Stopper] Stopping process: ffmpeg-38
I think there may be something wrong with your FFmpeg installation as it does not understand the 'preset' option. I compared the FFmpeg command line used with what is used on my computer and it is almost the same and works fine. The only real difference is the extra options "-hwaccel auto -threads 1 -ss 18" in mine.

Code: Select all

{mine} [ffmpeg64.exe-75] Starting "C:\Program Files (x86)\Universal Media Server\win32\ffmpeg64.exe" -y -loglevel info -hwaccel auto -threads 1 -ss 18 -t 6.0 -sn -i "D:\Users\Mik\Downloads\Video\Avenue 5 S02E05.mkv"     -sn -dn -copyts -s:v 640x360 -c:v libx264 -keyint_min 25 -preset superfast -profile:v main -level 30 -pix_fmt yuv420p -c:a aac -ac 6 -ab 320000 -f mpegts -skip_estimate_duration_from_pts 1 -use_wallclock_as_timestamps 1 -movflags frag_keyframe \\.\pipe\ffmpeghlsvideo_51627_1668878062796
{yours}[ffmpeg-38]       Starting /usr/bin/ffmpeg                                                    -y -loglevel info                                 -t 6.0 -sn -i "/home/media_mnt/Videos/Movies/Baby Driver (2017).mp4" -sn -dn -copyts -s:v 640x360 -c:v libx264 -keyint_min 25 -preset superfast -profile:v main -level 30 -pix_fmt yuv420p -c:a aac -ac 2 -ab 160000 -f mpegts -skip_estimate_duration_from_pts 1 -use_wallclock_as_timestamps 1 -movflags frag_keyframe /tmp/UMS-root/ffmpeghlsvideo_162_1666507845589
Since you are on Linux I don't really know how UMS is installed, if it installs FFmpeg itself or if you already had an old version on your computer that it chose to use instead and not update it.
The version you have installed is

Code: Select all

ffmpeg version 4.4.2 Copyright (c) 2000-2021 the FFmpeg developers
Where mine is using

Code: Select all

ffmpeg version 2022-08-31-git-319e8a49b5-essentials_build-www.gyan.dev Copyright (c) 2000-2022 the FFmpeg developers
See if you can manually update it, or try deleting that version and reinstall UMS.
I'm not sure if UMS is using a custom build of FFmpeg for the HLS transcoding used for the web player.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
boss
Posts: 361
Joined: Thu Jun 30, 2016 1:07 pm

Re: V11.5.0 from Web Browser

Post by boss »

Thanks for the reply.
After 2 years someone (yourself) has finally drilled down the issue.
I uninstalled ffmpeg (which is the latest stable Linux version) so UMS used its own included ffmpeg.
Watching videos from a browser worked fine after that,

Now to find out what is the problem with my Linux ffmpeg.

I will report back.

Thank you.
boss
Posts: 361
Joined: Thu Jun 30, 2016 1:07 pm

Re: V11.5.0 from Web Browser

Post by boss »

@mik_s

I got to the bottom of it.
The ffmpeg version included in UMS is a large file with support for xvid, x264 and x265 built in.
root root 50848812 Sep 6 09:20 /opt/ums/ums/linux/ffmpeg

The ffmpeg version with Gentoo Linux is a much smaller file and extra packages (eg: xvid, x264 and x265) have to be installed separately.
root root 289772 Nov 21 13:00 /usr/bin/ffmpeg

The UMS version has the following built in.
/opt/ums/ums/linux/ffmpeg -codecs |less
ffmpeg version N-62475-g130d19bf20-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2022 the FFmpeg developers
built with gcc 8 (Debian 8.3.0-6)
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gmp --enable-libgme --enable-gray --enable-libfribidi --enable-libass --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzimg


The Gentoo Linux version is (after I installed the xvid, x264 and x265 packages):
ffmpeg version 4.4.2 Copyright (c) 2000-2021 the FFmpeg developers
built with gcc 11.3.0 (Gentoo 11.3.0 p7)
configuration: --prefix=/usr --libdir=/usr/lib --shlibdir=/usr/lib --docdir=/usr/share/doc/ffmpeg-4.4.2/html --mandir=/usr/share/man --enable-shared --cc=i686-pc-linux-gnu-gcc --cxx=i686-pc-linux-gnu-g++ --ar=i686-pc-linux-gnu-ar --nm=i686-pc-linux-gnu-nm --strip=i686-pc-linux-gnu-strip --ranlib=i686-pc-linux-gnu-ranlib --pkg-config=i686-pc-linux-gnu-pkg-config --optflags='-O2 -march=i686 -pipe -fomit-frame-pointer' --extra-libs= --disable-static --enable-avfilter --enable-avresample --disable-stripping --disable-optimizations --disable-libcelt --disable-indev=v4l2 --disable-outdev=v4l2 --disable-indev=oss --disable-indev=jack --disable-indev=sndio --disable-outdev=oss --disable-outdev=sndio --enable-bzlib --disable-runtime-cpudetect --disable-debug --disable-gcrypt --enable-gnutls --disable-gmp --enable-gpl --disable-hardcoded-tables --enable-iconv --disable-libxml2 --disable-lzma --enable-network --disable-opencl --disable-openssl --enable-postproc --disable-libsmbclient --disable-ffplay --disable-sdl2 --disable-vaapi --disable-vdpau --disable-vulkan --disable-xlib --disable-libxcb --disable-libxcb-shm --disable-libxcb-xfixes --enable-zlib --disable-libcdio --disable-libiec61883 --disable-libdc1394 --disable-libcaca --disable-openal --disable-opengl --disable-libv4l2 --disable-libpulse --disable-libdrm --disable-libjack --disable-libopencore-amrwb --disable-libopencore-amrnb --disable-libcodec2 --enable-libdav1d --disable-libfdk-aac --disable-libopenjpeg --disable-libbluray --disable-libgme --disable-libgsm --disable-libaribb24 --disable-mmal --disable-libmodplug --disable-libopus --disable-libilbc --disable-librtmp --disable-libssh --disable-libspeex --disable-libsrt --disable-librsvg --disable-ffnvcodec --disable-libvorbis --disable-libvpx --disable-libzvbi --disable-appkit --disable-libbs2b --disable-chromaprint --disable-cuda-llvm --disable-libflite --disable-frei0r --disable-libvmaf --disable-libfribidi --disable-fontconfig --disable-ladspa --disable-libass --disable-libtesseract --disable-lv2 --disable-libfreetype --disable-libvidstab --disable-librubberband --disable-libzmq --disable-libzimg --disable-libsoxr --enable-pthreads --disable-amf --disable-libvo-amrwbenc --disable-libkvazaar --disable-libaom --disable-libmp3lame --disable-libopenh264 --disable-librav1e --disable-libsnappy --disable-libsvtav1 --disable-libtheora --disable-libtwolame --disable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-neon --disable-vfp --disable-vfpv3 --disable-armv8 --disable-mipsdsp --disable-mipsdspr2 --disable-mipsfpu --disable-altivec --disable-vsx --disable-power8 --disable-amd3dnow --disable-amd3dnowext --disable-fma4 --disable-xop --cpu=i686 --disable-doc --disable-htmlpages --enable-manpages


Before I installed the xvid, x264 and x265 packages and enabled them in ffmpeg, it was:
--disable-libx264 --disable-libx265 --disable-libxvid

It seems to be working fine now with just those 3 packages enabled in my Gentoo Linux ffmpeg.

Thank you for checking and giving me some direction with this.

Cheers
User avatar
mik_s
Moderator
Posts: 1181
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: V11.5.0 from Web Browser

Post by mik_s »

Glad that was it.

It was a hunch I had after seeing the command was the same but yours did not understand one of the options giving an error.
That option was probably only used for HLS in V11 so the main cause remained hidden in your previous logs.

I think if FFmpeg is already installed on Linux then it will take priority over the version UMS installs. I don't know enough to be sure though.

I'm sure I have seen that UMS uses a fork of FFmpeg for some features so that may be why the version you had appeared to be the latest and never got updated.

I found a bit in the UMS.conf that would allow you to tell UMS which version to use. Its in the "Non-GUI Options" section if you need to use the other version.

Code: Select all

# Path to ffmpeg (absolute or relative from project.binaries.dir)
# Example: /usr/bin/ffmpeg
# Default:
#     Win: win32/ffmpeg.exe
#     Mac: osx/ffmpeg
#     Linux: ffmpeg + system PATH
ffmpeg_path =
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
boss
Posts: 361
Joined: Thu Jun 30, 2016 1:07 pm

Re: V11.5.0 from Web Browser

Post by boss »

Yes, UMS uses the system ffmpeg by default unless configured otherwise.
Seeing as it seems to be working OK now I will leave UMS using the system ffmpeg.

Thanks again
Post Reply